require

(PHP 4, PHP 5, PHP 7)

requireinclude几乎完全一样,除了处理失败的方式不同之外。require在出错时产生E_COMPILE_ERROR级别的错误。换句话说将导致脚本中止而include只产生警告(E_WARNING),脚本会继续运行。

参见include文档了解详情。